Roy Tanck‘s Flick Widget requires Flash Player 9 or better.

Maybe I haven’t been paying attention, but I haven’t seen too many new widgets for displaying flickr photos recently. Yeah, it’s made with Flash and makes my browser a bit wonky, but I still like the concept of this one that Roy Tanak has made available on his website.